最长公共子序列

问题:求两个字符串的最长公共子序列
题目1042:Coincidence
时间限制:1 秒内存限制:32 兆特殊判题:否提交:4093解决:2241
题目描述:
Find a longest common subsequence of two strings.
输入:
First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.
输出:
For each case, output k – the length of a longest common subsequence in one line.
样例输入:
abcd
cxbydz
样例输出:
2
来源:
2008年上海交通大学计算机研究生机试真题
分析:
递推公式

dp[0][j](0<=j<=m)
dp[i][0](0<=i<=n)
dp[i][j]=dp[i-1][j-1]+1;
dp[i][j] =max(dp[i][j-1],dp[i-1][j]);

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#define MAX 101 
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int dp[MAX][MAX];
int max(int a,int b){
    if(a>b){
        return a;
    }else{
        return b;
    }
}
int main(int argc, char** argv) {
    char str1[MAX],str2[MAX];

    while(scanf("%s%s",str1,str2) != EOF){
        int len1=strlen(str1);
        int len2 = strlen(str2);


        for(int i=0;i<len1;i++){
            dp[i][0] = 0;
        }
        for(int i=0;i<len2;i++){
            dp[0][i]= 0;
        }
        for(int i=1;i<=len1;i++){
            for(int j=1;j<=len2;j++){
                if(str1[i-1] == str2[j-1]){
                    dp[i][j] = dp[i-1][j-1]+1;
                }else{
                    dp[i][j] = max(dp[i][j-1],dp[i-1][j]);
                }
            }
        }

        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值