点击链接PAT乙级-AC全解汇总
题目:
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
我的代码:
#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
#include<set>
#include<map>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<cstring>
#include<sstream>
using namespace std;
//有的时候题目是一起做的,所以会有不需要的头文件
int main()
{
int num[26]={0};
string str;
getline(cin,str);
for(int i=0;i<str.length();i++)
{
char temp=str[i];
if(temp>='a'&&temp<='z')
num[temp-'a']++;
else if(temp>='A'&&temp<='Z')
num[temp-'A']++;
}
int big_id=0;
for(int i=0;i<26;i++)
{
if(num[big_id]<num[i])big_id=i;
}
printf("%c %d",'a'+big_id,num[big_id]);
return 0;
}