River Hopscotch(sort+二分法)

River Hopscotch

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

     Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).
To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.
Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toM rocks (0 ≤ M ≤ N).
FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

【题意】这年代,就连牛也爱运动起来,这不,举行过河比赛。河宽L,牛牛们想过河

就要从河里的N块石头上跳过(石头的坐标为距离出发河岸的距离),但是每头牛可以

跳的距离是一定的,约翰先生为了使自己的牛赢,要把石头去掉M块(不能去掉开始和

结尾出的石头),问去掉M块石头后任意两块石头间的最短距离。


【思路】1 sort函数把石块按到起始点的大小由小到大排序;

        2 用二分法判断mid(假设为去掉m快石头的最短石头间的距离)


【注释】此处judge函数用的巧妙,能既去掉石头,又避开重新排序,自行推导方觉奥


AC代码:

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
int stone[50010];
int L, N, M;
int judge(int mid)
{
	int i, sum=0, x=0;
	for(i=1; i<=N+1; i++)
	{
		if( stone[i] - stone[x]<mid )
	        sum++;
	    else
	        x=i;
	}   
	return sum;
} 
int main()
{
	cin>>L>>N>>M;
	int i,j=0;
	stone[0]=0; stone[N+1]=L;//总共N+2快石头 
	for(i=1; i<=N; i++)
		cin>>stone[i];  
	sort(stone, stone+N+1);
	int left=0, right=L;
	int ans;
	while( right-left>=0 )
	{
		int mid = (left + right)/2;
		if( judge(mid) <= M )
		{
			ans=mid;
			left = mid + 1;
		}    
		else
		    right = mid - 1;	
	}
	printf("%d\n",ans);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值