简单bfs HDU a strange lift

A strange lift
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 65   Accepted Submission(s) : 30
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

 

题意:

输入一个N代表总共有的楼层数,A代表最低楼层,B代表最高楼层。再输入N个数,比如第X个数是5,表示从X这层可以向上上到第(X+5)层楼,向下可以下到第(X-5)层楼(前提是(X+5)和(X-5)属于1N的范围内),问最少需要乘电梯多少次可以从AB

 

BFS的简单题

 

AC代码如下

#include <iostream>

#include <cstdio>

#include <queue>

#include <cstring>

#include <algorithm>

using namespace std;

int N,A,B;

int change[210];  //数组change[210]用于储存对应层数可上/下的层数

int vis[210];    //vis[210]用于存储每层的访问与否状态,因为要求最短路径,走过的层数再走一遍会使路径变长

int dir[2]={1,-1};//用于储存方向,上/

struct node

{

    int f,step;//ffloor的缩写,代表层数,step代表当前走了多少次

};

 

int bfs()

{

    queue<node>Q;//定义一个队列Q

    node c,next; //定义结构体node变量cnext  c代表当前变量,next代表下一个变量

    c.f=A;//当前层数赋值为第一层的层数

    c.step=0;//未行走,step初始化为0

    vis[c.f]=1;//当前层状态设置为已访问

    Q.push(c);//将当前变量压栈

    while(!Q.empty())//如果直到所有的层数遍历完之后没有到达最后一层,跳出while循环,return-1

    {

        c=Q.front();//将对头赋值给c

        Q.pop();//弹出对头

        if(c.f==B)//完成题目要求时的终止条件,返回此时的的step就是所求

            return c.step;

        for(int i=0;i<2;i++)

        {

            next.f=c.f+dir[i]*change[c.f];

            if(!vis[next.f]&&next.f>0&&next.f<=N)//next的位置未访问且在1N内进行如下操作

            {

                vis[next.f]=1;

                next.step=c.step+1;

                Q.push(next);

            }

        }

    }

    return -1;

}

int main()

{

    while(~scanf("%d",&N))

    {

        if(N==0) break;

        scanf("%d%d",&A,&B);

        memset(vis,0,sizeof(vis));  //每次都把vis[210]的初始状态设为0 表示未访问过

        for(int i=1;i<=N;i++)

            scanf("%d",&change[i]);

        printf("%d\n",bfs());

    }

    return 0;

}

 

 

 

 

 

 

 

 

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值