1635: [Usaco2007 Jan]Tallest Cow 最高的牛 ——by lethalboy

1635: [Usaco2007 Jan]Tallest Cow 最高的牛

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 569   Solved: 338
[ Submit][ Status][ Discuss]

Description

FJ's N (1 <= N <= 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 <= H <= 1,000,000) of the tallest cow along with the index I of that cow. FJ has made a list of R (0 <= R <= 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17. For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

有n(1 <= n <= 10000)头牛从1到n线性排列,每头牛的高度为h[i](1 <= i <= n),现在告诉你这里面的牛的最大高度为maxH,而且有r组关系,每组关系输入两个数字,假设为a和b,表示第a头牛能看到第b头牛,能看到的条件是a, b之间的其它牛的高度都严格小于min(h[a], h[b]),而h[b] >= h[a]

Input

* Line 1: Four space-separated integers: N, I, H and R

 * Lines 2..R+1: Two distinct space-separated integers A and B (1 <= A, B <= N), indicating that cow A can see cow B.

Output

* Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8


INPUT DETAILS:

There are 9 cows, and the 3rd is the tallest with height 5.

Sample Output

5
4
5
3
4
4
5
5
5

HINT

Source

Silver



对于这道题,可以发现所给的几个(x,y)若看做区间,一定不会相交,都是相离或包含。那么既然要求最大,我们就对区间(x+1,y-1)减1,最终答案就是最大高度+单点值。区间修改单点查询我用的是线段树,然而网上的神犇们都写得差分数组,原谅我太弱不会差分数组。。。。


附代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<climits>
#include<map>
#define M 400010
#define N 100010
using namespace std;
map < pair<int,int> , bool > mp;
pair<int,int>p;
int n,ll,h,r;
int a[N];
struct edge{int l,r,tag,val;}e[M];
void build(int u,int l,int r)
{
	e[u].l=l,e[u].r=r,e[u].tag=e[u].val=0;
	if(l==r)return;int mid=(l+r)>>1;
	build(u<<1,l,mid);build(u<<1|1,mid+1,r);
}
void pushdown(int u)
{
	if(e[u].tag)
		{
			e[u<<1].val+=e[u].tag*(e[u<<1].r-e[u<<1].l+1);
			e[u<<1].tag+=e[u].tag;
			e[u<<1|1].val+=e[u].tag*(e[u<<1|1].r-e[u<<1|1].l+1);
			e[u<<1|1].tag+=e[u].tag;e[u].tag=0;
		}
}void pushup(int u){e[u].val=e[u<<1].val+e[u<<1|1].val;}
void add(int u,int x,int y,int v)
{
	int l=e[u].l,r=e[u].r;pushdown(u);
	if(x<=l&&y>=r)
		{
			e[u].val+=(r-l+1)*v;
			e[u].tag+=v;return;
		}int mid=(l+r)>>1;
	if(y<=mid)add(u<<1,x,y,v);
	else if(x>mid)add(u<<1|1,x,y,v);
	else {add(u<<1,x,y,v);add(u<<1|1,x,y,v);}
	pushup(u);
}
int query(int u,int x)
{
	int l=e[u].l,r=e[u].r,mid=(l+r)>>1;
	pushdown(u);if(l==r)return e[u].val;
	if(x<=mid)return query(u<<1,x);
	else return query(u<<1|1,x);
}
int main()
{
	scanf("%d%d%d%d",&n,&ll,&h,&r);
	build(1,1,n);
	for(int i=1,x,y;i<=r;i++)
		{
			scanf("%d%d",&x,&y);
			if(x>y)swap(x,y);
			if(x+1>y-1)continue;
			p.first=x,p.second=y;
			if(mp[p])continue;mp[p]=1;
			add(1,x+1,y-1,-1);
		}
	for(int i=1;i<=n;i++)printf("%d\n",h+query(1,i));
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值