1653: [Usaco2006 Feb]Backward Digit Sums

1653: [Usaco2006 Feb]Backward Digit Sums

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 433   Solved: 302
[ Submit][ Status][ Discuss]

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 3 1 2 4 4 3 6 7 9 16 Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. Write a program to help FJ play the game and keep up with the cows.

Input

* Line 1: Two space-separated integers: N and the final sum.

Output

* Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input


4 16

Sample Output


3 1 2 4

OUTPUT DETAILS:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4
is the lexicographically smallest.

HINT

Source

Silver



今天真的是要刷水题刷到死。。。。。。。

STL的全排列生成器叫 next_permutation(st,ed);
!!!注意,是tation而非nation。。。。。。
原谅我英语太差。。。


附代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<climits>
#include<cstring>
#include<string>
#include<fstream>
#define N 11
using namespace std;
int n,sum;
int a[N],b[N];
int main()
{
	scanf("%d%d",&n,&sum);
	for(int i=1;i<=n;i++)a[i]=i;
	do
		{
			for(int i=1;i<=n;i++)b[i]=a[i];
			int now=n;
			while(now!=1)
				{
					now--;
					for(int i=1;i<=now;i++)
						b[i]=b[i]+b[i+1];
				}
			if(b[1]==sum)break;
		}while(next_permutation(a+1,a+1+n));
	for(int i=1;i<=n;i++)
		{
			printf("%d",a[i]);
			if(i!=n)printf(" ");
		}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值