1664: [Usaco2006 Open]County Fair Events 参加节日庆祝

1664: [Usaco2006 Open]County Fair Events 参加节日庆祝

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 396   Solved: 282
[ Submit][ Status][ Discuss]

Description

Farmer John has returned to the County Fair so he can attend the special events (concerts, rodeos, cooking shows, etc.). He wants to attend as many of the N (1 <= N <= 10,000) special events as he possibly can. He's rented a bicycle so he can speed from one event to the next in absolutely no time at all (0 time units to go from one event to the next!). Given a list of the events that FJ might wish to attend, with their start times (1 <= T <= 100,000) and their durations (1 <= L <= 100,000), determine the maximum number of events that FJ can attend. FJ never leaves an event early.

 

有N个节日每个节日有个开始时间,及持续时间. 牛想尽可能多的参加节日,问最多可以参加多少. 注意牛的转移速度是极快的,不花时间.

Input

* Line 1: A single integer, N.

* Lines 2..N+1: Each line contains two space-separated integers, T and L, that describe an event that FJ might attend.

Output

* Line 1: A single integer that is the maximum number of events FJ can attend.

Sample Input

7
1 6
8 6
14 5
19 2
1 8
18 3
10 6

INPUT DETAILS:

Graphic picture of the schedule:
11111111112
12345678901234567890---------这个是时间轴.
--------------------
111111 2222223333344
55555555 777777 666

这个图中1代表第一个节日从1开始,持续6个时间,直到6.

Sample Output

4

OUTPUT DETAILS:

FJ can do no better than to attend events 1, 2, 3, and 4.

HINT

Source

Silver



同类的题好像见过很多道了。。。。。。

按右端点sort后dp即可


附代码:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<climits>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<map>
#define N 200200
using namespace std;
int n,f[N],ans;
struct node{int l,r;}p[N];
bool cmp(node a,node b)
{return a.r==b.r?a.l<b.l:a.r<b.r;}
int main()
{
//	freopen("in.txt","r",stdin);
//	freopen("my.txt","w",stdout);
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		{
			int l,x;
			scanf("%d%d",&l,&x);
			p[i].l=l,p[i].r=l+x-1;	
		}sort(p+1,p+1+n,cmp);
	for(int u=1;u<=n;u++)
		for(int j=0;j<p[u].l;j++)
			f[p[u].r]=max(f[p[u].r],f[j]+1);
	for(int i=1;i<N;i++)ans=max(ans,f[i]);
	printf("%d\n",ans);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值