2102: [Usaco2010 Dec]The Trough Game

2102: [Usaco2010 Dec]The Trough Game

Time Limit: 10 Sec   Memory Limit: 64 MB
Submit: 147   Solved: 109
[ Submit][ Status][ Discuss]

Description

Farmer John and Bessie are playing games again. This one has to do with troughs of water. Farmer John has hidden N (1 <= N <= 20) troughs behind the barn, and has filled some of them with food. Bessie has asked M (1 <= M <= 100) questions of the form, "How many troughs from this list (which she recites) are filled?". Bessie needs your help to deduce which troughs are actually filled. Consider an example with four troughs where Bessie has asked these questions (and received the indicated answers): 1) "How many of these troughs are filled: trough 1" --> 1 trough is filled 2) "How many of these troughs are filled: troughs 2 and 3" --> 1 trough is filled 3) "How many of these troughs are filled: troughs 1 and 4" --> 1 trough is filled 4) "How many of these troughs are filled: troughs 3 and 4" --> 1 trough is filled From question 1, we know trough 1 is filled. From question 3, we then know trough 4 is empty. From question 4, we then know that trough 3 is filled. From question 2, we then know that trough 2 is empty. 求N位二进制数X,使得给定的M个数,满足X and Bi=Ci ,Bi ci分别是读入的两个数

Input

* Line 1: Two space-separated integers: N and M * Lines 2..M+1: A subset of troughs, specified as a sequence of contiguous N 0's and 1's, followed by a single integer that is the number of troughs in the specified subset that are filled.

Output

* Line 1: A single line with: * The string "IMPOSSIBLE" if there is no possible set of filled troughs compatible with Farmer John's answers. * The string "NOT UNIQUE" if Bessie cannot determine from the given data exactly what troughs are filled. * Otherwise, a sequence of contiguous N 0's and 1's specifying which troughs are filled.

Sample Input

4 4
1000 1
0110 1
1001 1
0011 1

Sample Output

1010

HINT

Source

Silver


总共只有2^20个状态,直接暴力即可

附代码:

#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<climits>
#include<queue>
#include<stack>
#include<map>
#include<set>
#define N 101
using namespace std;
int n,m;
char mp[N][N];
int num[N],p[N];
int cal(int x){int len=0;while(x){if(x&1)len++;x>>=1;}return len;}
bool check(int u)
{
	for(int i=1;i<=m;i++)
		{
			int t=u&num[i];
			if(cal(t)!=p[i])return false;
		}
	return true;
}int ans,cnt,fin[N];
void print(int x)
{
	int j=n;
	while(x)
		{
			fin[j]=x&1;
			x>>=1;j--;
		}
	for(int i=1;i<=n;i++)printf("%d",fin[i]);
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++)
		{
			scanf("%s%d",mp[i]+1,&p[i]);
			for(int j=n;j;j--)
				if(mp[i][j]=='1')num[i]|=(1<<(n-j));
		}
	for(int i=1;i<(1<<n);i++)
		if(check(i))ans=i,cnt++;
	if(!cnt)printf("IMPOSSIBLE\n");
	else if(cnt>1)printf("NOT UNIQUE\n");
	else print(ans);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值