POJ - 3070 - Fibonacci ( 矩阵快速幂 )

描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875

 
#include<cstdio>
#include<cstring>
#include<iostream>
#define MOD 10000
using namespace std;
int n;
struct Matrix{
	int matrix[2][2];
}m1,m2,m3; 
//矩阵乘法 
Matrix f1(Matrix m1,Matrix m2){
	Matrix m3;
	memset(m3.matrix,0,sizeof(m3.matrix));
	for(int i=0 ;i<2;i++){
		for(int j=0 ;j<2 ;j++){
			for(int x=0 ;x<2 ;x++){
				m3.matrix[i][j]+=(m1.matrix[i][x]*m2.matrix[x][j])%MOD;
			}
		}
	}
	return m3; 
}

//快速幂
Matrix f2(Matrix m4,int n){
	Matrix m5;
	if(n==1){
		return m4;
	}
	else if(n==2){
		return f1(m4,m4);
	}
	else if(n%2==0){
		m5 = f2(f1(m4,m4),n/2);
		return m5;
	}
	else{
		m5 = f2(f1(m4,m4),n/2);
		return f1(m5,m4);
	}
}

 


int main(){
	while(cin>>n){
		if(n==0)cout<<0<<endl;
		else if(n==-1)break;
		else{
			Matrix ans;
			Matrix temp;
			Matrix in;
			in.matrix[0][0]=1;
			in.matrix[0][1]=1;
			in.matrix[1][0]=1;
			in.matrix[1][1]=0;
			ans = f2(in,n);
			cout<<ans.matrix[0][1]%MOD<<endl;
		}
		
	}
	
	
	return 0;
}        

#include<cstdio>
#include<cstring>
#define MOD 10000
#define N 31
using namespace std;
int n;
struct mat{
	long long v[N][N];	
	mat(){memset(v,0,sizeof(v));}
};

mat mul(mat x,mat y){
	mat ans;
	for(int i= 0;i<n ;i++){
		for(int j=0 ;j<n ;j++){
			for(int k=0 ;k<n ;k++){
				ans.v[i][j] = (ans.v[i][j]+x.v[i][k]*y.v[k][j])%MOD;
			}
		}
	}
	return ans;
	
}
//乘法 
mat pow(mat x ,int k){
	mat ans;
	//初始化ans为单位矩阵 
	ans.v[0][0] = 1 ; ans.v[0][1] = 0;
	ans.v[1][0] = 0; ans.v[1][1] = 1;
	while(k){
		if(k&1) ans = mul(ans,x) ;
		x = mul(x,x);
		k >>= 1;
	}
	return ans;
}

int main(){
	int k;
	n=2;
	mat m1 ;
	m1.v[0][0] = 1 ; m1.v[0][1] = 1;
	m1.v[1][0] = 1; m1.v[1][1] = 0;
	while(scanf("%d",&k)!=EOF&&k!=-1){
		mat ans;
		ans = pow(m1,k);
		printf("%lld\n",ans.v[0][1]);
	}
	
	return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值