PAT - 甲级 - 1086. Tree Traversals Again (25)(已知中序+先序求后序)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

给定条件:
1.二叉树中序遍历+先序遍历

要求:
1.二叉树后序遍历

解:
2.递归建树,建树过程中可以记录后序遍历结果


#include<cstdio>
#include<vector>
#include<string>
#include<stack>
#include<iostream>
using namespace std;

vector<int>pre,post,inorder;
stack<int>st;
string s;
int n;
int id = 0;
void dfs(int l1, int r1, int l2, int r2){
	if(l1 > r1) return ;

	int i = 0;
	while(pre[l1] != inorder[i]) i++;

	dfs(l1+1, l1+i-l2, l2, i-1);
	dfs(l1+i-l2+1, r1, i+1, r2);
	post.push_back(pre[l1]);
}

int main(){
	freopen("input.txt", "r", stdin);

	scanf("%d", &n);
	while(cin>>s){
		int num;
		if(s[2] == 's'){
			scanf("%d", &num);
			st.push(num);
			pre.push_back(num);
		}else{
			inorder.push_back(st.top());
			st.pop();
		}
	}

	dfs(0, n-1, 0, n-1);
	for(int i = 0; i < n; i++){
		if(i) printf(" ");
		 printf("%d",post[i]);
	}
	printf("\n");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值