An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print ythe root of the resulting AVL tree in one line.
Sample Input 1:5 88 70 61 96 120Sample Output 1:
70Sample Input 2:
7 88 70 61 96 120 90 65Sample Output 2:
88
给定条件:
1.n个节点
要求:
1.用这n个节点建立平衡二叉搜索树,并且输出根节点的值
求解:
1.裸的AVL,建议搜索相关知识进行学习。思路全部都一样,不一样的是你手下的代码,(你喜欢哪种风格?):p
2.以下给出参考代码:
#include<cstdio>
#define max(a,b) ((a) > (b) ? (a) : (b))
struct node {
int val;
node *left, *right;
};
node *LL(node *root){
node *t = root->left;
root->left = t->right;
t->right = root;
return t;
}
node *RR(node *root){
node *t = root->right;
root->right = t->left;
t->left = root;
return t;
}
node *LR(node *root){
root->left = RR(root->left);
return LL(root);
}
node *RL(node *root){
root->right = LL(root->right);
return RR(root);
}
int getHeight(node *root){
if(root == nullptr) return 0;
return max(getHeight(root->left), getHeight(root->right)) + 1;
return 1;
}
node *insert(node *root, int val){
if(root == nullptr) {
root = new node();
root->val = val;
root->left = root->right = nullptr;
} else if(val < root->val) {
root->left = insert(root->left, val);
if(getHeight(root->left) - getHeight(root->right) == 2)
root = val < root->left->val ? LL(root) : LR(root);
} else {
root->right = insert(root->right, val);
if(getHeight(root->left) - getHeight(root->right) == -2)
root = val > root->right->val ? RR(root) : RL(root);
}
return root;
}
int main(){
int n, val;
node *root = nullptr;
scanf("%d", &n);
for(int i = 0; i < n; i++) {
scanf("%d",&val);
root = insert(root, val);
}
printf("%d\n", root->val);
return 0;
}