PAT - 甲级 - 1082. Read Number in Chinese (25)(字符串处理)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai


给定条件:
1.给定一个整数

要求:
1.“读出”这个数

求解思路:
1.先试着每个数字都读出来,找出错误的地方
2.发现ling和wan需要特殊处理
4.依次处理每一位,需要特殊处理的增加判断条件即可
5.具体看代码


#include <cstdio>
#include <iostream>
#include <vector>
using namespace std;

int n;
vector<string> v;
string num[10] = {"ling", "yi", "er", "san", "si", "wu", "liu", "qi", "ba", "jiu"};

int main() {
	scanf("%d", &n);
	if(n == 0){
		printf("ling\n");
		return 0;
	}

	if(n < 0) {
		n *= -1;
		printf("Fu ");
	}

	int cnt = 0;
	while(n > 0) {
		switch(cnt){
			case 1 : if(n%10)v.push_back("Shi"); break;
			case 2 : if(n%10)v.push_back("Bai"); break;
			case 3 : if(n%10)v.push_back("Qian"); break;
			case 4 : if(n%10 || n/10%10 || n/10/10%10 || n/10/10/10%10)v.push_back("Wan"); break;
			case 5 : if(n%10)v.push_back("Shi"); break;
			case 6 : if(n%10)v.push_back("Bai"); break;
			case 7 : if(n%10)v.push_back("Qian"); break;
			case 8 : if(n%10)v.push_back("Yi"); break;
		}
		if(n%10 == 0) {
			if(!v.empty() && v[v.size()-1] != "ling" ) {
				if(v[v.size()-1] != "Shi" && v[v.size()-1] != "Bai" && v[v.size()-1] != "Qian" && v[v.size()-1] != "Wan")
				v.push_back(num[n%10]);
			}
		}else {
			v.push_back(num[n%10]);	
		}
		cnt++;
		n /= 10;
	}

	for(int i = v.size()-1; i > 0; i--){
		printf("%s ", v[i].c_str());
	}
	printf("%s\n", v[0].c_str());
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值