1142. Maximal Clique (25)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line “Yes” if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print “Not Maximal”; or if it is not a clique at all, print “Not a Clique”.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique


题目大意:
给定条件:给定结点之间的连接关系。
要求判断给定的一些结点是否是Clique,是否为Maximal
Cilque的含义是给定的所有结点之间,都有一条直接相连的边。
Maximal的含义是无论再加入哪个点,都会破坏Cilque的条件。


#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;

int e[205][205], res = 0;
int nv, ne, a, b, k, t;
vector<int> v;
int vis[205];


// 判断是否是Clique 
// 返回1:是 返回0:否
int judge1(vector<int> vt) {
    for (int i = 0; i < (int)vt.size(); i++) {
        for (int j = 0; j < (int)vt.size(); j++) {
            if (i != 0 && e[vt[i]][vt[j]] == 0) return 0;
        }
    } 
    return 1;
}
// 判断是否是Maximal
// 返回1: 不是  返回0:是
void judge2(vector<int> vt, int n) {
    if ((int)vt.size() - 1 == n) {
        res = judge1(vt) || res;
        return ;
    } 
    for (int i = 1; i <= nv; i++) {
        if (find(vt.begin(), vt.end(), i) != vt.end()) continue;
        vt.push_back(i);
        judge2(vt, n);
        vt.pop_back();
    }
}
int main() {
    scanf("%d%d", &nv, &ne);
    memset(e, 0, sizeof(e));
    for (int i = 0; i < ne; i++) {
        scanf("%d%d", &a, &b);
        e[a][b] = e[b][a] = 1;
        e[a][a] = e[b][b] = 1;
    }
    scanf("%d", &t);

    while (t--) {
        scanf("%d", &k);
        res = 0; v.clear();
        for (int i = 0; i < k; i++) {
            scanf("%d", &a);
            v.push_back(a);
        }
        if (judge1(v) == 0) {
            printf("Not a Clique\n");
            continue;
        }
        judge2(v, (int)v.size());
        if (res == 0) {
            printf("Yes\n");
        } else {
            printf("Not Maximal\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值