HDU1242(优先队列,最短路)Rescue


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

求最短路时,用到BFS
#include <iostream>
#include <cstdio>
#include <cstring>
#include <fstream>
#include <queue>
#include <vector>
#define maxn 210
#define INF 100000000
using namespace std;
typedef pair<int, int> P;
char ma[maxn][maxn];
int bf[maxn][maxn];
int si, sj, ei, ej;
int di[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
int n, m;


//最短路径
//有没有路径的情况
//输出最短路径

//百度提示用优先队列


int bfs()
{
    queue<P> que;
    for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                bf[i][j] = INF;
    que.push(P(si, sj));
     bf[si][sj] = 0;
     while(que.size())
     {
         P p = que.front();
         que.pop();
         if(p.first == ei && p.second == ej)
            break;
         for(int i = 0; i < 4; i++)
         {
             int x = p.first + di[i][0];
             int y = p.second + di[i][1];
             //inf有无访问过
             if(bf[x][y] == INF && x >= 1 && x <= n && y >= 1 && y <= m && ma[x][y] != '#')
             {
                 que.push(P(x, y));
                 if(ma[x][y] == 'x')
                 {
                     bf[x][y] =  bf[p.first][p.second] + 2;
                 }
                 else
                 {
                     bf[x][y] =  bf[p.first][p.second] + 1;
                 }

             }
         }
     }
     return bf[ei][ej];
}
int main()
{
    //freopen("in.txt", "r", stdin);
    while(~scanf("%d %d", &n, &m))
    {
        getchar();
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m; j++)
            {
                scanf("%c", &ma[i][j]);
                if(ma[i][j] == 'r')
                {
                    si = i;;
                    sj = j;
                }
                else if(ma[i][j] == 'a')
                {
                    ei = i;
                    ej = j;
                }
            }
            getchar();
        }
        int ans = bfs();
        if(ans == INF)
        {
            printf("Poor ANGEL has to stay in the prison all his life.\n");

        }
        else
        {
            printf("%d\n", ans);
        }
    }
    return 0;
}



尴尬,果然过段时间不看,搜索又忘了....

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值