HDU 1258 (DFS) Sum It Up

Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
  
  
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 

Sample Output
  
  
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25


哈哈,第一次这么快弄出来搜索题,感动


在最开始输入数据的时候,建立值和个数两个数组, 再建立数组保存某数值用的个数,当加和等于 t 的时候,就可以把数据输出,输出个数就是之前保存的那个因为是按照数值由大到小输出,所以在判断某值使用个数的时候,要由大到0,这样就能保证是由大到小输出的


#include <iostream>
#include <cstdio>
#include <cstring>
#include <fstream>
int num[15];
int flag[15];
int val[15];
int t, n, total, f;
using namespace std;

//一个数字可能出现多次
//保留数字个数?

//当前加和值,当前顺序位置,当前数值的个数

void dfs(int sum, int order)
{
    if(sum == t)
    {
        f = 1;
        int f2 = 0;
        for(int i = 1; i <= order; i++)
        {
            for(int j = 0; j < flag[i]; j++)
            {
                if(f2)
                {
                    printf("+%d", val[i]);
                }
                else
                {
                    f2 = 1;
                    printf("%d", val[i]);
                }
            }
        }
        printf("\n");
        return;
    }
    if(order == total + 1)
        return;
    for(int i = num[order]; i >= 0; i--)
    {
        flag[order] = i;//用了几个
        dfs(sum + val[order] * i, order + 1);
        flag[order] = 0;
    }
    return;
}
int main()
{
    //freopen("in.txt", "r", stdin);
    while(~scanf("%d%d", &t, &n))
    {
        if(n == 0)
            break;
        total = 0;
        val[0] = -1;
        f = 0;
        memset(num, 0, sizeof(num));
        for(int i = 1; i <= n; i++)
        {
            int k;
            scanf("%d", &k);
            if(k == val[total])
            {
                num[total]++;
            }
            else
            {
                total++;
                val[total] = k;
                num[total] = 1;

            }
        }
        memset(flag, 0, sizeof(flag));
        printf("Sums of %d:\n", t);
        dfs(0, 1);
        if(f == 0)
            printf("NONE\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值