hdu--2803 The MAX(sort排序)

The MAX(sort)
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F. 
 

Input

Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output

For each test case, output the biggest value of F you can find on a line.
 

Sample Input

     
     
2 1 2 0
 

Sample Output

     
     
4017

注意:数据类型为long long否者会出错
代码;
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	long long a[110];
	while(scanf("%d",&n)&&n)
	{
		long long sum=0;
		for(int i=0;i<n;i++)
		{
			scanf("%lld",&a[i]);
		}
		sort(a,a+n);
		for(int i=0;i<n-1;i++)
		{
			sum+=a[i];
		}
		sum+=(2010-n)*a[n-1];
		printf("%lld\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值