LIght OJ 1058

H - H
Time Limit: 2000 MS      Memory Limit: 32768 KB      64bit IO Format: %lld & %llu

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

Input starts with an integer T (≤ 15), denoting the number of test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

For each case, print the case number and the number of parallelograms that can be formed.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

Case 1: 5

Case 2: 6

题意: 计算平行四边形的个数,,,,,

思路:用结构体记录任意两个点之间的x坐标和与y坐标和,(相当于这两个点作为一条对角线的情况),然后找出对角线相交于同一点的个数k(结构体中的x和y相等),然后C(k,2)就OK,因为若多条对角线相交于同一个中点,则任意选择两条就可以构成一个平行四边形;

代码:

#include<stdio.h> 
#include<string.h>
#include<algorithm> 
using namespace std;
int x[1001];
int y[1001];
struct node
{
	int x;
	int y;
}a[1000*1000/2];
int cmp(node a,node b)
{
	if(a.x!=b.x)
	{
		return a.x<b.x;
	}
	else
	return a.y<b.y;
}
int main()
{
	int t,n,mm=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);
		}
		int t=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				a[t].x=x[i]+x[j];
				a[t].y=y[i]+y[j];
				t++;
			}
		}
		int num=0,ans=1,cnt=0;
		sort(a,a+t,cmp);
		for(int i=1;i<t;i++)
		{
			if(a[i].x==a[num].x&&a[i].y==a[num].y)
			{
				ans++;//记录经过一个中点的对角线的个数; 
			}
			else
			{
				cnt+=ans*(ans-1)/2;//计算经过这个中点的平行四边形的个数; 
				num=i;//记录经过下一个中点的一条对角线,作为后面比较的对象; 
				ans=1;//每次计算经过不同中点的对角线个数时,都要初始化为1; 
			}
		}
		printf("Case %d: %d\n",mm++,cnt);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值