Div 3

Div3 
Time Limit: 2000 MS      Memory Limit: 32768 KB      64bit IO Format: %lld & %llu

Description

There is sequence 1, 12, 123, 1234, ..., 12345678910, ... . Now you are given two integers A and B, you have to find the number of integers from Ath number to Bth (inclusive) number, which are divisible by 3.

For example, let A = 3. B = 5. So, the numbers in the sequence are, 123, 1234, 12345. And 123, 12345 are divisible by 3. So, the result is 2.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains two integers A and B (1 ≤ A ≤ B < 231) in a line.

Output

For each case, print the case number and the total numbers in the sequence between Ath and Bth which are divisible by 3.

Sample Input

2

3 5

10 110

Sample Output

Case 1: 2

Case 2: 67

思路:打表直接会超时,换种方法做;

打出前十几个数会发现这样的一个规律:0 1 2 2 3 4 4 5 6 6 7 8 8……,这时就需要找规律来优化算法;

可以以3为一个周期,则从0到a[i]被3整除的个数为若a[i]被3整除是a[i]/3*2,否则为a[i]/3*2+a[i]%3-1;

代码:

#include<stdio.h>
int f(int x)
{
	int a=x/3;
	if(x%3==0)
	return a*2;
	else
	return a*2+x%3-1; 
}
int main()
{
	int t,a,b,mm=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&a,&b);
		int c=f(b)-f(a-1);
		printf("Case %d: %d\n",mm++,c);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值