POJ1679-判断MST是否唯一

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 29027 Accepted: 10372

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!


题目大意:给你一张联通图,判断最小生成树是否唯一,如果唯一输出值,否则输出“Not Unique!” 

题目思路:这题有很多方法,第一种是先求一遍普利姆,然后删去其中一条边在求次普利姆看权值是否相同,这个复杂度是0(n^3) 第二种是用克鲁斯卡尔,先求一遍克鲁斯卡尔然后把边都标记,然后sort一下,规则为如果值相同就把标记过后的边放在前面,再求一遍克鲁斯卡尔,如果出现了没有被标记的边说明不唯一,这个时间复杂度为O(n*logn)但是常数比较大,当然还有大神用prim的n^2的算法,就是prim时求出每两个点之间的最短距离,最后再判断是否唯一,我这里用的是第二种方法!


AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

struct st{
   int u,v,w,flag;
}s[20000];

bool cmp(st a,st b){
    if(a.w==b.w)return a.flag<b.flag;
    return a.w<b.w;
}
int n,m;

int pre[105];

int get(int x){
   if(x!=pre[x])return pre[x] = get(pre[x]);
   return pre[x];
}

void klu(bool is){
     for(int i=1;i<=n;i++)pre[i]=i;
     sort(s,s+m,cmp);
     int num = 0;
     int flag = 0;
     int ans = 0;
     for(int i=0;i<m;i++){
        int x = get(s[i].u);
        int y = get(s[i].v);
        if(x!=y){
            pre[x] = y;
            num++;
            ans+=s[i].w;
            if(is){
                if(!s[i].flag){flag=1;break;}
            }
            s[i].flag = 1;
        }
        if(num==n-1)break;
     }
     if(is){
        if(flag)printf("Not Unique!\n");
        else printf("%d\n",ans);
     }
}

int main()
{
    int t;cin>>t;
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&s[i].u,&s[i].v,&s[i].w);
            s[i].flag = 0;
        }
        klu(0);
        klu(1);
    }
    return 0;
}

 




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值