HDU2444-判断是否能构成二分图

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5931    Accepted Submission(s): 2703


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
 


题目大意:

                      给你一张图,判断是否能构成二分图,如果能求出最大匹配


题目思路:

                可以直接bfs进行染色,如果在同一集合中的点的颜色不相同则说名不能构成,否则能够成二分图然后进行最大匹配


AC代码:

#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
const int maxn = 250;
using std::vector;
using std::queue;
vector<int>edge[maxn];

bool vis[maxn];
int link[maxn];
int n,m;

bool dfs(int u){
    for(int i=0;i<edge[u].size();i++){
        int v = edge[u][i];
        if(!vis[v]){
            vis[v]=true;
            if(link[v]==-1||dfs(link[v])){
                link[v]=u;
                return true;
            }
        }
    }
    return false;
}

bool bfs(int u){           //bfs染色判断
    link[u]=0;
    queue<int>q;
    q.push(u);
    while(!q.empty()){
        u = q.front();q.pop();
        for(int i=0;i<edge[u].size();i++){
            int v = edge[u][i];
            if(link[v]==-1){link[v]=link[u]^1;q.push(v);}
            else {
                if(link[v]==link[u])return false;   //在不同集合中且颜色相同
            }
        }
    }
    return true;
}

int main()
{

    while(~scanf("%d%d",&n,&m)){
        memset(link,-1,sizeof(link));
        memset(edge,0,sizeof(edge));
        while(m--){
            int u,v;scanf("%d%d",&u,&v);
            edge[u].push_back(v);
            edge[v].push_back(u);
        }
        int flag=0;
        for(int i=1;i<=n;i++){
            if(link[i]==-1){
                if(!bfs(i)){
                    flag=1;
                    break;
                }
            }
        }
        if(flag){
            printf("No\n");
            continue;
        }
        memset(link,-1,sizeof(link));
        int ans = 0;
        for(int i=1;i<=n;i++){
            memset(vis,false,sizeof(vis));
            if(dfs(i))ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值