Alisha’s Party
Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 6064 Accepted Submission(s): 1461
Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value
v
, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.
Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.
If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.
Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.
If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.
Input
The first line of the input gives the number of test cases,
T
, where
1≤T≤15
.
In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000 . The door would open m times before all Alisha’s friends arrive where 0≤m≤k . Alisha will have q queries where 1≤q≤100 .
The i−th of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1≤vi≤108 , separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi .
Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.
The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.
Note: there will be at most two test cases containing n>10000 .
In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000 . The door would open m times before all Alisha’s friends arrive where 0≤m≤k . Alisha will have q queries where 1≤q≤100 .
The i−th of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1≤vi≤108 , separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi .
Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.
The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.
Note: there will be at most two test cases containing n>10000 .
Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
Sample Input
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
Sample Output
Sorey Lailah Rose
Source
题目大意:
有k个人每个人都有个权值,依次来到一个城堡,m次操作,每次操作为:a b 表示当地a个人来到的时候可以进去b个人,如果m次操作后还有人没有进去则全部进去,优先进去权值大的,如果权值一样则先来的先进去,顺序为按照输入的顺序,然后给你q次查询,每次查询输入a 输出第a个进去的人的名字
题目思路:
首先没说m次操作的a是否按顺序给出,所以我们要先给m次操作按a排个序,然后就可以用个优先队列,对于第i此操作的ai(i>1)
把从ai-1 - ai的人入队,然后出队bi个就是依次进入进入城堡的顺序,最后如果队列不为空,则全部出队,出队的顺序就是进入城堡的顺序,保存起来,然后查询时直接输出
AC代码:
#include<bits/stdc++.h>
using namespace std;
int k,m,q;
struct st //保存进入城堡的人的
{
char s[203];
int v;
int id;
bool operator<(const st&a)const
{
if(a.v==v)return a.id<id;
return a.v>v;
}
}s[150005];
struct nod //操作数
{
int x,y;
bool operator <(const nod &a)const
{
return a.x>x;
}
}ss[150005];
int main()
{
int t;cin>>t;
while(t--)
{
scanf("%d%d%d",&k,&m,&q);
map<int,string>ans;
for(int i=1;i<=k;i++)
{
scanf("%s %d",s[i].s,&s[i].v);
s[i].id = i;
}
map<string,int>flag;
int cnt = 1;
int xx=0;
priority_queue<st>qmax;
for(int i=1;i<=m;i++)
{
scanf("%d%d",&ss[i].x,&ss[i].y);
}
sort(ss+1,ss+m+1);
for(int i=1;i<=m;i++)
{
int x = ss[i].x,y = ss[i].y;
for(int i=xx+1;i<=x;i++)
{
qmax.push(s[i]);
}
while(y--&&!qmax.empty())
{
st a = qmax.top();
qmax.pop();
ans[cnt++] = a.s;
}
xx = x;
}
for(int i=xx+1;i<=k;i++)qmax.push(s[i]);
while(!qmax.empty())
{
ans[cnt++] = qmax.top().s;
qmax.pop();
}
while(q--)
{
int x;scanf("%d",&x);
cout<<ans[x];
if(q)printf(" ");
}
printf("\n");
}
return 0;
}