hdu1009-贪心

7 篇文章 0 订阅
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 
题意:给你M个 cat food,让你去换javabean。问怎么才能得到最大数量的javabean。
思路:贪心的思想,按照单位catfood能够得到的javabean从大到小排序,然后先拿走最贵的。
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Node
{
    double javabean;
    double catfood;
    double uv;
}node[1005];
bool cmp(Node n1,Node n2)
{
    return n1.uv>n2.uv;
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        if(m==-1&&n==-1)
            break;
        for(int i=0;i<n;i++){
            scanf("%lf%lf",&node[i].javabean,&node[i].catfood);
            node[i].uv=(node[i].javabean*1.0)/node[i].catfood;
        }
        sort(node,node+n,cmp);
        int i;
        double sum=0;
        for(i=0;i<n;i++){
            if(m>node[i].catfood){
                m-=node[i].catfood;
                sum+=node[i].javabean;
            }
            else{
                sum+=node[i].uv*m;
                break;
            }

        }
        printf("%.3lf\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值