Asteroids(二分图匹配)

64 篇文章 0 订阅
53 篇文章 1 订阅
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).


题目大意:要求你横着或者竖着开枪消灭一行或者一列的飞船还是什么,求最小开枪次数

解题思路:这是二分图匹配的模板,主要是存下来二分图的模板,以后可以用,二分图关键是构建图形,然后把模板套上去就可以了

#include<iostream>  
#include<cstdio>
#include<stdio.h>
#include<cstring>  
#include<cstdio>  
#include<climits>  
#include<cmath> 
#include<vector>
#include <bitset>
#include<algorithm>  
#include <queue>
#include<map>
using namespace std;

vector<int> G[2500];
int a[505], flag[505];
int n, k;
bool dfs(int x)
{
	int i;
	for (i = 0; i < G[x].size(); i++)
	{
		if (a[G[x][i]]==0)
		{
			a[G[x][i]] = 1;
			if (flag[G[x][i]]==0||dfs(flag[G[x][i]]))//是否这个点已经占据或者是否占据这个点的可以换一个找到未被占据的点
			{
				flag[G[x][i]] = x;//这个点被占据
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int i, sum, x, y;
	memset(flag, 0, sizeof(flag));//标记是否该点已经匹配
	cin >> n >> k;
	for (i = 1; i <= k; i++)
	{
		cin >> x >> y;
		G[x].push_back(y);
	}
	sum = 0;
	for (i = 1; i <= n; i++)
	{
		memset(a, 0, sizeof(a));
		if (dfs(i))
		{
			sum++;
		}
	}
	cout << sum << endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值