POJ2955Brackets(区间DP模板题)

64 篇文章 0 订阅
53 篇文章 1 订阅
Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7556 Accepted: 4020

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

题目大意:给你一串字符串,然后求出来这个字符串中,最长的符号匹配串,也就是说(()),[[]],[][]这样是匹配的,而这样[[],(][))就不是

解题思路:这是个区间DP,dp[j][k]表示j到k匹配长度,要是dp[j]==dp[k]相同,意味着dp[j][k]=dp[j+1][k-1]+2

#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
using namespace std;

int main()
{
	int i, j, u, k, n;
	int dp[105][105];
	for (;;)
	{
		string str;
		cin >> str;
		if (str == "end")
		{
			return 0;
		}
		memset(dp, 0, sizeof(dp));
		n = str.length();
		for (i = 1; i < n; i++)//区间长度
		{
			for (j = 0,k=i; k < n; k++,j++)//区间头尾位置
			{
				if (str[j] == '['&&str[k] == ']' || str[j] == '('&&str[k] == ')')
				{
					dp[j][k] = dp[j + 1][k - 1] + 2;
				}
				for (u = j; u <=k; u++)
				{
					dp[j][k] = max(dp[j][u] + dp[u+1][k], dp[j][k]);
				}
			}
		}
		cout << dp[0][n - 1] << endl;
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值