HDU - 5025 2014 ACM/ICPC Asia Regional Guangzhou Online D题Saving Tang Monk(BFS+优先队列)

64 篇文章 0 订阅
25 篇文章 4 订阅

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2533    Accepted Submission(s): 890


Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M).

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
  
  
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
  
  
5 impossible 8
 

Source
 

Recommend
hujie
 

题目大意:n*n的矩阵中要求从K走到T,同时遇到S的时候要多加一秒,且要按照12345这样的顺序拿矩阵数字,.表示通过,#不能通过,求最短路径
解题思路:这道题是一个bfs,但是与bfs不同的是,在队列中的部署不是升序的,bfs的原理是,先出队列的且满足条件那么她一定是最短路径,但是这道题由于要考虑到S也就是打妖怪需要多浪费一秒,意味着在队列中所走长度不是升序排列,所以要使用优先队列维护,之后就是裸的bfs,同时要注意到的是,拿钥匙要记着该拿哪个钥匙,路过这个点有妖怪是否打了没,就在结构体里面存储一个妖怪的数组保存,拿钥匙的个数判断是否是该位置-1,也就是要四个状态,方向两个状态x,y,妖怪一个状态,钥匙一个状态,但是要是四维标记会T,所以可以把妖怪那一维存在结构体中,用三维数组标记是否以某个状态走过这个点
#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
#include<stack>
using namespace std;


int dix[4] = { 1,0,-1,0 };
int diy[4] = { 0,1,0,-1 };
int n, m, ans;
char tu[105][105];
bool vis[105][105][10];
char snake[105][105];
struct Monkey
{
	int x, y;
	bool snakes[6];
	int sum, key;
	friend bool operator< (Monkey n1, Monkey n2)
	{
		if (n1.sum == n2.sum)
		{
			return n1.key < n2.key;
		}
		return n1.sum > n2.sum;
	};
};

void bfs(int x, int y)
{

	int i;

	bool flag = false;
	Monkey monkey, m1, mm;
	monkey.x = x;
	monkey.y = y;
	monkey.key = 0;
	memset(monkey.snakes, 0, sizeof(monkey.snakes));
	monkey.sum = 0;
	priority_queue <Monkey> qua;
	qua.push(monkey);
	vis[monkey.x][monkey.y][0] = true;
	while (!qua.empty())
	{
		monkey = qua.top();
		qua.pop();
		mm = monkey;
		if (tu[mm.x][mm.y] == 'T'&&mm.key == m)
		{
			ans = mm.sum;
			return;
		}
		for (i = 0; i < 4; i++)
		{
			m1 = monkey;
			m1.x = monkey.x + dix[i];
			for (int j = 0; j < 6; j++)
			{
				m1.snakes[j] = monkey.snakes[j];
			}
			m1.y = monkey.y + diy[i];
			m1.sum++;
			if (m1.x > n || m1.x < 1 || m1.y<1 || m1.y>n || vis[m1.x][m1.y][m1.key] == true||tu[m1.x][m1.y]=='#')
			{
				continue;
			}
			vis[m1.x][m1.y][m1.key] = true;
			if (tu[m1.x][m1.y] == 'S')
			{
				if (m1.snakes[snake[m1.x][m1.y] - 'a'] == false)
				{
					m1.sum++;
					m1.snakes[snake[m1.x][m1.y] - 'a'] = true;
				}
			}
			else if (tu[m1.x][m1.y] == m1.key + 1 + '0')
			{
				m1.key++;
			}
			qua.push(m1);
		}
	}
	//return flag;
}
int main()
{
	int i, j, ss, x, y;
	for (;;)
	{
		cin >> n >> m;
		ans = -1;
		memset(vis, 0, sizeof(vis));
		memset(snake, 0, sizeof(snake));
		//scanf("%d %d", &n, &m);
		if (n == 0 && m == 0)
			break;
		ss = 0;
		for (i = 1; i <= n; i++)
		{
			for (j = 1; j <= n; j++)
			{
				//scanf("%c", &tu[i][j]);
				cin >> tu[i][j];
				if (tu[i][j] == 'K')
				{
					x = i, y = j;
				}
				if (tu[i][j] == 'S')
				{
					snake[i][j] ='a'+ss;
					ss++;
				}
			}
		}
		bfs(x, y);
		if (ans!=-1)
		{
			//printf("%d\n", ans);
			cout << ans << endl;
		}
		else
		{
			//printf("impossible\n");
			cout << "impossible" << endl;
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值