2017 ACM/ICPC Asia Regional Shenyang Online E题

99 篇文章 2 订阅
roblem Description
We define a sequence  F:

  F0=0,F1=1;
  Fn=Fn1+Fn2 (n2).

Give you an integer  k, if a positive number  n can be expressed by
n=Fa1+Fa2+...+Fak where  0a1a2ak, this positive number is  mjfgood. Otherwise, this positive number is  mjfbad.
Now, give you an integer  k, you task is to find the minimal positive  mjfbad number.
The answer may be too large. Please print the answer modulo 998244353.
 

Input
There are about 500 test cases, end up with EOF.
Each test case includes an integer  k which is described above. ( 1k109)
 

Output
For each case, output the minimal  mjfbad number mod 998244353.
 

Sample Input
 
 
1
 

Sample Output
 
 
4
 

Source
 

Recommend

liuyiding




沈阳赛区网络赛分到的第二道题,列出前几项之后会发现答案刚好是第2*n+3项斐波那契数-1,考虑到数据比较大,弄个快速幂求斐波那契就可以了。

#include <iostream>  
#include <cstddef>  
#include <cstring>  
#include <vector>  
using namespace std;  
typedef long long ll;  
const int mod=998244353;  
typedef vector<ll> vec;  
typedef vector<vec> mat;  
mat mul(mat &a,mat &b) //快速幂模板 
{  
    mat c(a.size(),vec(b[0].size()));  
    for(int i=0; i<2; i++)  
    {  
        for(int j=0; j<2; j++)  
        {  
            for(int k=0; k<2; k++)  
            {  
                c[i][j]+=a[i][k]*b[k][j];  
                c[i][j]%=mod;  
            }  
        }  
    }  
    return c;  
}  
mat pow(mat a,ll n)  
{  
    mat res(a.size(),vec(a.size()));  
    for(int i=0; i<a.size(); i++)  
        res[i][i]=1;  
    while(n)  
    {  
        if(n&1) res=mul(res,a);  
        a=mul(a,a);  
        n/=2;  
    }  
    return res;  
}  
ll solve(ll n)  
{  
    mat a(2,vec(2));  
    a[0][0]=1;  
    a[0][1]=1;  
    a[1][0]=1;  
    a[1][1]=0;  
    a=pow(a,n);  
    return a[0][1]; 
}  
int main()  
{  
    ll n;  
    while(cin>>n&&n!=-1)  
    {  
        cout<<solve(2*n+3)-1<<endl;  
    }  
    return 0;  
}  





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值