HDU6047 2017 Multi-University Training Contest - Team 2Maximum Sequence(贪心)

25 篇文章 4 订阅
9 篇文章 0 订阅

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 432    Accepted Submission(s): 232


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1a2n . Just like always, there are some restrictions on an+1a2n : for each number ai , you must choose a number bk from {bi}, and it must satisfy ai ≤max{ aj -j│ bk ≤j<i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo 109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo 109 +7。
 

Sample Input
  
  
4 8 11 8 5 3 1 4 2
 

Sample Output
  
  
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
 

Source
 

Recommend
liuyiding
 

题目大意:存在T组数据,每个数据会给N个数据和两个数组,第一个数组是每个位置的大小,第二个数组是第一个数组的下标,现在希望能够求第一个数组n+1到2*n的数据大小的和,这n个数据的放置规则是在第一个数组的i位置到末尾中数值减下标的最大值,同时这个选择的这个最大值的下标要大于等于第二个数组的某个下标,第二个数组的值每个只能用一次
解题思路:对于某个最大值来说,我希望尽可能的使用他将他补充到第一个数组中,所以我要将第二个数组进行排序,每次抽取最小的,但是维护第一个数组很麻烦,为此比赛的时候,我考虑的是单调队列,但是队友用了优先队列过了,下来补题的时候,得知单纯用数组就可以
我可以从后往前橹第一个数组,对于当前位置到最后的这个区间的最大值,然后在对n+1到2*n进行补充的时候,我们每次补充后,取一个MAX,然后对将要选择的区间的最大值进行比较,取最大值放到第一个数组中
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

LL pt=1e9+7;
LL cnt,sum;
LL a[250010],ans[250010];
int b[250010];
int main()
{
 //freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
	while(cin>>n)
	{
		int i;
		memset(ans,0,sizeof(ans));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=1;i<=n;i++) 
		{
			cin>>a[i];
			a[i]-=i;
		}
		ans[n]=a[i];
		for(i=n-1;i>=1;i--)
			ans[i]=max(a[i],ans[i+1]);
		for(i=1;i<=n;i++) cin>>b[i];
		sort(b+1,b+1+n);
		sum=0;
		cnt=0;
		for(i=1;i<=n;i++)
		{
			if(cnt<ans[b[i]])
				sum=(sum+ans[b[i]])%pt;
			else
				sum=(sum+cnt)%pt;
			cnt=max(cnt,ans[b[i]]-(n+i));
		}
		cout<<sum<<endl;
			
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值