The Unique MST POJ - 1679 (次小生成树模板)

50 篇文章 0 订阅
17 篇文章 0 订阅
The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32148 Accepted: 11633

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

题目大意:现在给你n个点,m个边,然后判断是否最小生成树是唯一的

解题思路:判断是否最小生成树是唯一的,需要判断是次小生成树是否与最小生成树相同即可,首先我们需要生成一个最小生成树,这样的话,我们对于最小生成树中的每个边进行枚举删除,然后在删除掉最小生成树的一个边的情况下生成的最小生成树是否唯一即可

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;


struct point
{
	int x,y,c;
}a[10005];
int sum,n,m,cnt;
int check[10005],path[10005];;
void init()
{
	for(int i=1;i<=n;i++)
		 check[i]=i;
}
int find(int x)
{
	if(check[x]==x)
		return x;
	check[x]=find(check[x]);
	return check[x];
}
bool cmp(point x,point y)
{
	return x.c<y.c;
}
bool merage(int x,int y)
{
	int t1=find(x);
	int t2=find(y);
	if(t1!=t2)
	{
		check[t2]=t1;
		return true;
	}
	else
		return false;
}
void Kruskal()
{
	int i;
	init();
	sort(a+1,a+1+m,cmp);
	for(i=1;i<=m;i++)
	{
		if(merage(a[i].x,a[i].y))
		{
			cnt++;
			path[cnt]=i;//将生成最小生成树的边的下标记下来
			sum+=a[i].c;//算出最小生成树的权值和
		}
		if(cnt==n-1)
			break;
	}
}
bool mst()
{
	int ans,i,j;
	int k;
	for(i=1;i<=cnt;i++)//枚举最小生成树中的边
	{
		ans=0,k=0;
		init();
		for(j=1;j<=m;j++)
		{
			if(j==path[i]) continue;
			if(merage(a[j].x,a[j].y))
			{
				k++;
				ans+=a[j].c;
			}
		}
		if(k==n-1&&ans==sum)//判断在删除一个边的情况下,是否生成了一个次小生成树与最小生成树的权值相同
			return false;
	}
	return true;
}
int main()
{
	int T,i;
	cin>>T;
	while(T--)
	{
		memset(check,0,sizeof(check));
		memset(a,0,sizeof(a));
		memset(path,0,sizeof(path));
		sum=0;
		cnt=0;
		cin>>n>>m;
		for(i=1;i<=m;i++)
		{
			cin>>a[i].x>>a[i].y>>a[i].c;
		}
		Kruskal();//预处理出来一个最小生成树
		if(mst())
		{
			cout<<sum<<endl;
		}
		else
		{
			cout<<"Not Unique!"<<endl;
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值