POJ-1679 The Unique MST(次小生成树模板题)

该博客探讨了如何确定一个连接的无向图的最小生成树是否唯一。它定义了什么是生成树和最小生成树,并提供了输入输出示例。文章通过解决次小生成树模板问题来检查最小生成树的唯一性,如果最小生成树和次小生成树相同,则说明最小生成树不唯一。
摘要由CSDN通过智能技术生成

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

 问最小生成树是否唯一?唯一输出最小生成树大小,否则输出:Not Unique!

 次小生成树模板题,求出最小生成树和次小生成树,如果两者相等,则最小生成树不唯一

AC:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f
#define M 101
using namespace std;
int mp[M][M],path[M][M];//path求的是i到j最大的边权
int dist[M],pre[M],vis[M];
bool used[M][M];//是否在最小生成树中
int n,m,mst;

void init()
{
    for(int i=0;i<=n;i++)
        for(int j=i+1;j<=n;j++)
            mp[i][j]=mp[j][i]=inf;
}

int prime()
{
    int mst=0;
    memset(path,0,sizeof(path));
    memset(vis,0,sizeof(vis));
    memset(used,0,sizeof(used));
    vis[1]=1;
    for(int i=1;i<=n;i++)
    {
        dist[i]=mp[1][i];
        pre[i]=1;
    }
    for(int i=1;i<n;i++)
    {
        int u=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j])
                if(u==-1||dist[j]<dist[u])
                    u=j;
        }
        used[u][pre[u]]=used[pre[u]][u]=true;//加入mst
        mst+=mp[pre[u]][u];
        vis[u]=1;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]&&j!=u)//从u到j这条路径上最大边的权值
                path[j][u]=path[u][j]=max(path[j][pre[u]],dist[u]);
            if(!vis[j])
                if(dist[j]>mp[u][j])//更新相邻节点的距离
                {
                    dist[j]=mp[u][j];
                    pre[j]=u;//记录他的前驱
                }
        }
    }
    return mst;
}

int second_tree()//求次小生成树
{
    int res=inf;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            if(i!=j&&!used[i][j])
                res=min(res,mst-path[i][j]+mp[i][j]);//删除树上权值最大的路径并且加上这条路径其它边
    return res;
}

int main()
{
    int t,a,b,d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&d);
            mp[a][b]=mp[b][a]=d;
        }
        mst=prime();//最小生成树
        int second_mst=second_tree();//次小生成树
        if(mst==second_mst)
            printf("Not Unique!\n");
        else printf("%d\n",mst);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值