Codeforces Educational Codeforces Round 105 B. Berland Crossword

B. Berland Crossword

time limit per test2 seconds
memory limit per test256 megabytes
inputstandard input
outputstandard output
Berland crossword is a puzzle that is solved on a square grid with n rows and n columns. Initially all the cells are white.

To solve the puzzle one has to color some cells on the border of the grid black in such a way that:

exactly U cells in the top row are black;
exactly R cells in the rightmost column are black;
exactly D cells in the bottom row are black;
exactly L cells in the leftmost column are black.
Note that you can color zero cells black and leave every cell white.

Your task is to check if there exists a solution to the given puzzle.

Input
The first line contains a single integer t (1≤t≤1000) — the number of testcases.

Then the descriptions of t testcases follow.

The only line of each testcase contains 5 integers n,U,R,D,L (2≤n≤100; 0≤U,R,D,L≤n).

Output
For each testcase print “YES” if the solution exists and “NO” otherwise.

You may print every letter in any case you want (so, for example, the strings yEs, yes, Yes and YES are all recognized as positive answer).

输入样例
4
5 2 5 3 1
3 0 0 0 0
4 4 1 4 0
2 1 1 1 1

输出样例
YES
YES
NO
YES

解题思路

判定四个角的使用情况,使用一个角会使用相邻的两个数,如果存在一种情况使四个数都在0~n-2中
那么说明条件成立

AC代码

#include <iostream>
using namespace std;
int n;
int check(int x) {
	return (x>=0&&x<=n-2);
}
int main() {
	int t ;
	cin>>t;
	while(t--) {
		int flag=0;
		int u,r,d,l;
		cin>>n>>u>>r>>d>>l;
		for(int t1=0; t1<=1; t1++)
			for(int t2=0; t2<=1; t2++)
				for(int t3=0; t3<=1; t3++)
					for(int t4=0; t4<=1; t4++) {
						int x1=u-t1-t2;
						int x2=r-t2-t3;
						int x3=d-t3-t4;
						int x4=l-t4-t1;
						if(check(x1)&&check(x2)&&check(x3)&&check(x4)) {
							flag=1;
							break;
						}
					}
		if(flag)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;

	}
}```

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Nebula_xuan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值