poj 1285 Agri-Net

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51631 Accepted: 21536

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
这一题就是最小生成树的问题
大意是
/*
第一行是个数
接下来的是个数*个数的矩阵形式就是到其他的长度
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
#define MAX 0x3f3f3f3f
using namespace std;
int a1[102][102];
int dis[102];
struct node
{
    int x;
    int y;
    int z;
}a[10002];
int cmp(node p,node q)
{
    return p.z < q.z;
}
int find(int x)
{
    while(x!=dis[x])
    {
        x = dis[x];
    }
    return x;
}
int meget(int x,int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
    {
        dis[fx] = fy;
        return 1;
    }
    else
        return 0;
}
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
    int i,j,e = 0;
    for(i = 0;i < n; i++)
    {
        for(j = 0;j < n; j++)
        {
            scanf("%d",&a1[i][j]);
            if(j < i)
            {
                a[e].x = i;
                a[e].y = j;
                a[e++].z = a1[i][j];
            }
        }
    }
    sort(a,a+e,cmp);
    for(i = 0;i < n; i++)
    {
        dis[i] = i;
    }
    int sum = 0;
    int cont = 0;
    for(j = 0;j < e; j++)
    {
        if(meget(a[j].x,a[j].y))
        {
            sum = sum+a[j].z;
            cont++;
        }
        if(cont == n-1)
            break;
    }
    printf("%d\n",sum);
    }
}


代码菜鸟,如有错误,请多包涵!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值