poj 3096 Surprising Strings

Surprising Strings
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6902 Accepted: 4468

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
就是找隔着相同数量的字母的两个有没有重复的。如
ZGBG 隔着0个字母的有ZG GB BG没有相同的,ZB GG没有相同的, ZG 没有相同的,那这就是令人惊讶的
代码:
Memory: 692K		Time: 32MS
Language: G++		Result: Accepted
Source Code
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <map>
#include <iostream>
using namespace std;

int main()
{
    int i, j;
    char str[120];
    while ( scanf ( "%s", str ) && str[0] != '*' )
    {
        int len = strlen(str);
        int ok = 1;
        if ( len <= 2 )
        {
            printf ( "%s is surprising.\n", str );
            continue;
        }
        for ( i = 0;i <= len-2; i++ )
        {
            map<string, bool> ma;
            for ( j = 0;j < len-i-1; j++ )
            {
                char h[3] = { str[j], str[j+i+1], '\0' };
                if ( ma[h] != true )
                    ma[h] = true;
                else
                {
                    ok = 0;
                    break;
                }
            }
            if ( !ok )
                break;
        }
        printf ( ok ? "%s is surprising.\n" : "%s is NOT surprising.\n" , str );
    }
}
代码菜鸟,如有错误,请多包涵!!!
如有帮助记得支持我一下,谢谢!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值