Mobile phones poj 1195

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 18754 Accepted: 8651

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4
题意:
给出一个全0的矩阵,然后一些操作
0 S:初始化矩阵,维数是S*S,值全为0,这个操作只有最开始出现一次
1 X Y A:对于矩阵的X,Y坐标增加A
2 L B R T:询问(L,B)到(R,T)区间内值的总和
3:结束对这个矩阵的操作

一个二维的树状数组 只是树状数组要避免出现为0的下标

代码如下:
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

int num[1051][1051];
int n, m;

int lowbit(int x)
{
    return x&(-x);
}

void updata(int x, int y, int val)
{
    int i, j;
    for ( i = x;i <= m; i = i+lowbit(i) )
        for ( j = y;j <= m; j = j+lowbit(j) )
            num[i][j] = num[i][j]+val;
}

int query(int x, int y)
{
    int i, j, sum = 0;
    for ( i = x;i > 0; i = i-lowbit(i) )
        for ( j = y;j > 0;j = j-lowbit(j) )
            sum = sum+num[i][j];
    return sum;
}

int main()
{
    int h, sum, l, r;
    int x, y;
    scanf ( "%d %d", &n, &m );
    memset ( num, 0, sizeof(num) );
    while ( ~scanf ( "%d", &h )&&h != 3 )
    {
        if ( h == 1 )
        {
            scanf ( "%d %d %d", &x, &y, &sum );
            updata( x+1, y+1, sum );
        }
        else
        {
            scanf ( "%d %d %d %d", &x, &y, &l, &r );
            printf ( "%d\n", query(l+1, r+1)+query(x, y)-query(l+1, y)-query(x, r+1) );
        }
    }
    return 0;
}

代码菜鸟,如有错误,请多包涵!!!

如有帮助记得支持我一下,谢谢!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值