HDU 3001 Travelling By Assassin 3进制状压

Travelling
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6915 Accepted Submission(s): 2239

Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn’t want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.

Output
Output the minimum fee that he should pay,or -1 if he can’t find such a route.

Sample Input

2 1
1 2 100
3 2
1 2 40
2 3 50
3 3
1 2 3
1 3 4
2 3 10

Sample Output

100
90
7

三进制状压,dp[i]【j】代表在i状态下在j城市,注意特判如果出现两次就不行了

#include<bits/stdc++.h>
#define input freopen("input.txt","r",stdin)
using namespace std;
#define inf ((1<<30)-1)
int key[12][12];
int dp[59049][12];//i状态当前在j点
int dig[59049][12];//i状态j点去过几次
int thr[12]= {0,1,3,9,27,81,243,729,2187,6561,19683,59049};
int main(){
    //input;
    int n,m,i,j;
    int a,b,c;
    memset(dig,0,sizeof(dig));
    for(int i=0; i<59049; ++i)
    {
        int t=i;
        for(int j=1; j<=10&&t; ++j)
        {
            dig[i][j]=t%3;
            t/=3;
        }
    }
    //init();
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(key,-1,sizeof(key));
        memset(dp,-1,sizeof(dp));
        for(; m--;)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(key[a][b]==-1)
                key[a][b]=key[b][a]=c;
            else
                key[a][b]=key[b][a]=min(key[a][b],c);//消除重边
        }
        for(int i=1; i<=n; ++i) dp[thr[i]][i]=0;
        int ans=inf;
        for(int i=0; i<thr[n+1]; ++i)
        {
            bool flag=true;
            for(int j=1; j<=n; ++j)
            {
                if(!dig[i][j]) flag=false;
                if(dp[i][j]==-1) continue;
                for(int k=1; k<=n; ++k)
                {
                    if((k==j)||(key[j][k]==-1)||(dig[i][k]>=2))
                        continue;
                    if((dp[i+thr[k]][k]==-1)||(dp[i+thr[k]][k]>dp[i][j]+key[j][k]))
                        dp[i+thr[k]][k]=dp[i][j]+key[j][k];
                }
            }
            if(flag)
            {
                for(int j=1; j<=n; ++j)
                    if(dp[i][j]!=-1)
                        ans=min(ans,dp[i][j]);
            }
        }
        if(ans==inf) puts("-1");
        else         printf("%d\n",ans);
    }
    return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值