Cyclic Nacklace(KMP)

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12309 Accepted Submission(s): 5188

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input
3
aaa
abca
abcde

Sample Output
0
2
5

/*
 本体就是让求 在添加几个数让字符串变成一个循环子串
  分三种情况讨论 就是 让next[len] == 0 的话 说明 没有一个公共的前后缀 所以此时需要加 n个
  如果这个船本身就是一个循环串 (len % (len - next[len])==0) 呢吗就不需要加了
  这里求的是最小的周期
  如果不是一个循环串 那么就 总的串长度 - 循环的部分
  http://acm.hdu.edu.cn/showproblem.php?pid=3746
*/

#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>

using namespace std;
int nxt[100007];
char ch[100007];
void getNext(int len)
{
   nxt[0] = -1;
   int i =0,j = -1;
   while(i <len)
   {
       if(j == -1 || ch[i] == ch[j]) nxt[++i] = ++j;
       else
        j = nxt[j];
   }
}
int main()
{
    int ncase;
    scanf("%d",&ncase);
    while(ncase--)
    {
        scanf("%s",ch);
        int len = strlen(ch);
        getNext(len);
        int mn = len - nxt[len];
        if(!nxt[len]) printf("%d\n",len);//如果长度为len的 中最常前后缀为0 那么说明 还需要len 才开一个够成一个循环串
        else if(len % mn == 0) printf("0\n");//这里判断是否是一个循环字符串
        else
        {
            printf("%d\n",mn - len % mn);//如果不是一个循环串 求出省下的呢几位未循环的
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值