魔咒词典(简单的map的使用--STL)

魔咒词典
Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 346 Accepted Submission(s): 95

Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

这道题一看没多想直接用map水一个题结果一提交发现是内存超了 换了G++和C++提交内存都超了 后来看见讨论区里面的人说会用map直接秒 结果发现大多数人和我都是一样问题就是内存超了 最后发现了一个用map直接秒了的大神 并贴上我的内存超了代码
大神的代码:

#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;

struct cmp
{
    bool operator()(char *a, char *b) const
    {return strcmp(a, b) < 0;}
};

map<char *, char*, cmp>d;
char a[100010][24], b[100010][84], c[112];

int main()
{
    int M = 0, N;
    while (scanf("%[^\]\n]%*c", a[M]) && strcmp(a[M], "@END@"))
    {
        scanf("%*c%[^\n]\n", b[M]);
        d[a[M]] = b[M];
        d[b[M]] = a[M++];
    }
    scanf("%d\n", &N);
    while (N--)
    {
        gets(c);
        bool f = *c == '[';
        c[strlen(c)-f] = 0;
        if (d.find(c) != d.end())
            puts(d[c]+!f);
        else
            puts("what?");
    }
}

自己的代码:

#include<iostream>
#include<string>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>

using namespace std;

int main()
{
    map<string,string> mymap;
    string str;
    while(cin>>str&&str!="@END@")
    {
        string tt;
        getchar();
        getline(cin,tt);
        mymap[str] = tt;
        mymap[tt] = str.substr(1,str.size()-2);
    }
    int ncase;
    cin>>ncase;
    getchar();
    while(ncase--&&getline(cin,str))
    {
        if(mymap[str].size())
        {
            cout<<mymap[str]<<endl;

        }
        else
        {
              printf("what?\n");
        }

    }
    return 0;
}

我到现在也没有发现大神写的和我自己写的有什么区别,希望以后可以找出问题的所在

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值