A very hard mathematic problem HDU - 4282

A very hard mathematic problem HDU - 4282

Haoren is very good at solving mathematic problems. Today he is working a problem like this:
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.
Input
  There are multiple test cases.
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  
Output
  Output the total number of solutions in a line for each test case.
Sample Input
9
53
6
0
Sample Output
1
1
0
  

Hint
9 = 1^2 + 2^2 + 1 * 2 * 2
53 = 2^3 + 3^3 + 2 * 3 * 3

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
long long int pow_mod(long long int a,int b){
    long long int s=1,base=a;
    while(b){
        if (b&1)
        s*=base;
        b>>=1;
        base*=base;
    }
    return s;
}
using namespace std;
int main(){
    long long int k;
    long long int sum;
    while(~scanf("%lld",&k)&&k){
        sum=0;
        long long int qq=sqrt(k);
        if (qq*qq==k){
            sum+=(qq-1)/2;
        }
        for(int z=3;z<31;z++){
            for (int x=1;x<=65536;x++){
                long long int ss=pow_mod(x,z);
                if (ss*2>=k){
                    break;
                }
                for (int y=x+1;y<=65536;y++){
                    long long int sss=pow_mod(y,z);
                    if (ss+sss+x*y*z==k){
                        sum++;
                    }
                    else if (ss+sss+x*y*z<k){
                        continue;
                    }
                    else{
                        break;
                    }
                }
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值