POJ - 2955 

Brackets

Description:

We give the following inductive definition of a “regular brackets” sequence:
•the empty sequence is a regular brackets sequence,
•if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
•if a and b are regular brackets sequences, then ab is a regular brackets sequence.
•no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6


题目大意:
找一个括号序列中,最大的匹配子串。

解题思路:
用f[i][j]表示 从第i个位置到第j个位置的最大匹配数。
1.如果边界两个匹配,那么f[i][j] = f[i+1][j-1]+2。
2.如果边界不匹配,那么f[i][j] = max(f[i][j] , f[i][x] + f[x+1][j])。


源代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;

int n;
char a[1005];
int f[1005][1005];
int p,q;

int main(){
    while(scanf("%s",a)){
        if(a[0]=='e')
          break;
        n = strlen(a);
        memset(f,0,sizeof(f));
        for(int len=1;len<n;len++){
            for(int i=0,j=len;j<n;i++,j++){
                if(a[i]=='('&&a[j]==')' || a[i]=='['&&a[j]==']') 
                    f[i][j] = f[i+1][j-1]+2;
                for(int x=i;x<j;x++)   
                    f[i][j]=max(f[i][j],f[i][x]+f[x+1][j]);
                //cout<<i<<"  "<<j<<"   "<<f[i][j]<<endl;
            }
        }
        printf("%d\n",f[0][n-1]);
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值