POJ - 2955 Brackets 区间dp


题目链接

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10528 Accepted: 5577

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

给出一个 只有()[]的 字符串,问最多有多少括号能匹配(一对括号算2)

虽然看起来很像经典的堆栈应用,但是那个是判断是否完全匹配的,用于这个题目可能有实现难度(笔者没有什么头绪,可能有大神就是用堆栈做的)

首先笔者的解法为区间dp。

定义dp[i][j]为区间[i,j]的最大完全匹配数

那么对于dp[i][j]显然有 dp[i][j]=dp[i+1][j-1]+ matching(s[i],s[j])?2:0; 其中mathcing()为是否匹配

然后再进行状态转移就ok了

代码如下

#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
#include<queue>
#include<set>
#include<cstdio>
#include<functional>
#include<iomanip>
#include<cmath>
#include<stack>
using namespace std;
const int maxn = (int)(1e5) + 100;
const int inf = 0x3f3f3f3f;
const int mod = 2520;
const double eps = 1e-3;
typedef long long LL;
typedef unsigned long long ull;
int dp[111][111];
int main() {
	//freopen("E:\\test.txt", "r", stdin);
	char str[111];
	while (~scanf("%s", str+1), str[1] != 'e') {
		memset(dp, 0, sizeof(dp));
		int n = strlen(str+1);
		for (int len = 2; len <= n; len++) {
			for (int i = 1; i <= n; i++) {
				int j = i + len - 1;
				if (j > n) continue;
				if (str[i] == '('&&str[j] == ')' || str[i] == '['&&str[j] == ']') {
					dp[i][j] = dp[i + 1][j - 1] + 2;
				}
				for (int k = i; k < j; k++) {
					dp[i][j] = max(dp[i][j], dp[i][k] + dp[k+1][j]);
				}
			}
		}
		printf("%d\n", dp[1][n]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值