POJ 2031

Building a Space Station

description:

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor’, or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells’ surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n
x1 y1 z1 r1
x2 y2 z2 r2

xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834


题目大意:
在太空中将各个空间连接。每个空间看成一个三位的球体,并给出坐标与半径。如果两个空间之间有重叠部分则认为是连接的,不用建桥。现在求总共最短需要建立多长的桥才能将各个空间连接。(不考虑桥的交叉,每座桥就唯一连接两个空间)。

解题思路:
1.抛开问题的背景,就是一道最小生成树的问题。其中每个点之间都有一条路,这条路的权值为0 或者 中心距离减去两个半径。
2.选择c++编译器,读取应该用%lf,用G++编译器,读取用%f。


源代码:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<math.h>

using namespace std;

int n,e;
int fa[105];
struct edg{
    int start,end;
    double cost;
    bool operator < (const edg& a) const{
        return cost<a.cost;
    }
}; 
edg roads[10000];

struct point{
    double x,y,z;
    double r;
};
point ps[100];

int find(int x){
    int r=x;
    while(r!=fa[r])
        r=fa[r];
    int i=x,j;
    while(fa[i]!=r){
        j=fa[i];
        fa[i]=r;
        i=j;
    }
    return r;
}  

double kruskal(){
    for(int i=0;i<n;i++)
      fa[i] = i;
    sort(roads,roads+e);
    int now_choose=0;
    double total_cost = 0.0;
    for(int i=0;i<e;i++){
        int fs = find(roads[i].start);
        int fe = find(roads[i].end);        
        if(fs!=fe){
            fa[fs] = fe;
            total_cost+=roads[i].cost;
            now_choose++;
        }       
        if(now_choose==n-1)
          break;
    }
    if(now_choose<n-1)
      return 0.0;
    return total_cost;  
}

void init(){
    e = 0;
    for(int i=0;i<n;i++){
        for(int j=i+1;j<n;j++){
            double dis = sqrt( (ps[i].x-ps[j].x)*(ps[i].x-ps[j].x) + (ps[i].y-ps[j].y)*(ps[i].y-ps[j].y) + (ps[i].z-ps[j].z)*(ps[i].z-ps[j].z)  );
            //cout<<"distent : "<<dis<<"          "<<ps[i].r<<" + "<<ps[j].r<<endl;
            dis = dis>ps[i].r+ps[j].r?dis-ps[i].r-ps[j].r:0;
            roads[e].start = i;
            roads[e].end = j;
            roads[e].cost = dis;
            e++;
            //cout<<i<<"   "<<j<<"   "<<dis<<endl;
        }
    }
}

int main(){
    while(scanf("%d",&n),n){
        for(int i=0;i<n;i++){
            scanf("%lf%lf%lf%lf",&ps[i].x,&ps[i].y,&ps[i].z,&ps[i].r);
        }
        init();
        printf("%.3lf\n",kruskal());
    }
    return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值