1002 A+B for Polynomials (25 point(s))

1002 A+B for Polynomials (25 point(s))

This time, you are supposed to find A+B where A and B are two polynomials(多项式).

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents(指数) and coefficients(系数), respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

方法一:数组

#include <iostream>
#include <cstdio>

using namespace std;

int main(){
    
    int k;
    double coef[1001] = {0}; //因为数组最后是 \0,独占一位
    cin>>k;
    while(k--){
        int i;
        double j;
        cin>>i>>j;
        coef[i] += j;
    }
    cin>>k;
    while(k--){
        int i;
        double j;
        cin>>i>>j;
        coef[i] += j;
    }
    int sum = 0;  // 数组没有 size 和 length函数,必须这样子输出大小。
    for(int i=0;i<=1000;i++){
        if(coef[i]!=0) sum++;
    }
    cout<<sum;
    
    for(int i=1000;i>=0;i--){ // 输出从案例看明显是从大到小
        if(coef[i] != 0){
           //cout<<" "<<i<<" "<<coef[i]; 要求是保留一位精度,这种方式无法保证
           printf(" %d %.1f",i,coef[i]);
            
        }
    }
    
}

方法二:Map

#include <iostream>
#include <cstdio>
#include <map>

using namespace std;

int main(){
    
    int k;
    map<int,double> coef; //引入字典 map 数据结构
    cin>>k;
    while(k--){
        int i;
        double j;
        cin>>i>>j;
        coef[i] += j;
    }
    cin>>k;
    while(k--){
        int i;
        double j;
        cin>>i>>j;
        coef[i] += j;
        if(coef[i] == 0) coef.erase(i); // 如果两个多项式之和为零,则擦除该项
    }
    
    cout<<coef.size(); // map 可以这样直接输出大小
    
    for(auto it=coef.end();it!=coef.begin();){ // 输出从案例看明显是从大到小
        --it; // 容器类型的end都是不保留数据的,先减
       printf(" %d %.1f",it->first,it->second); //输出map中所有的元素,键⽤it->first获取,值⽤it->second获取
    }
    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值