1002 A+B for Polynomials (25point(s))

1002 A+B for Polynomials (25point(s))

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​ ​​ N​2​​ a​N​2​​ ​​ … N​K​​ a
​N​K where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K <⋯<N2 <N1 ≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

第三个用例一直不过,fuck

#include<bits/stdc++.h>
using namespace std;
struct polynomial{
    int exp;
    double coe;
}p1[15],p2[15],p3[25];
int main(){
    int k1,k2;
    cin>>k1;
    for(int i=0;i<k1;++i)
        cin>>p1[i].exp>>p1[i].coe;
    cin>>k2;
    for(int i=0;i<k2;++i)
        cin>>p2[i].exp>>p2[i].coe;
    int i,j,k;
    for(i=0,j=0,k=0;i<k1&&j<k2;){
        if(p1[i].exp>p2[j].exp){
            p3[k].exp=p1[i].exp;
            p3[k].coe=p1[i].coe;
            i++;
            k++;
        }
        else if(p1[i].exp<p2[j].exp){
            p3[k].exp=p2[j].exp;
            p3[k].coe=p2[j].coe;
            j++;
            k++;
        }
        else{
            p3[k].exp=p1[i].exp;
            p3[k].coe=p1[i].coe+p2[j].coe;
            i++;
            j++;
            if(p3[k].coe!=0)
                k++;
        }
    }
    while(i<k1){
        p3[k].exp=p1[i].exp;
        p3[k].coe=p1[i].coe;
        i++;
        k++;
    }
    while(j<k2){
        p3[k].exp=p2[j].exp;
        p3[k].coe=p1[j].coe;
        j++;
        k++;
    }
    cout<<k;
    for(int i=0;i<k;++i)
    {
        printf(" ");
        printf("%d %.1f",p3[i].exp,p3[i].coe);
    }        
    cout<<endl;
}

柳神的思路

#include<bits/stdc++.h>
using namespace std;
const int maxK=1000+10;
double p[maxK];
int main(){
    int k,n;
    double a;
    memset(p,0,sizeof(p));
    cin>>k;
    for(int i=0;i<k;++i){
        cin>>n;
        cin>>a;
        p[n]+=a;
    }
    cin>>k;
    for(int i=0;i<k;++i){
        cin>>n;
        cin>>a;
        p[n]+=a;
    }
    int count=0;
    for(int i=0;i<maxK;++i){
        if(p[i]!=0)
            count++;
    }
    cout<<count;
    for(int i=maxK-1;i>=0;--i){
        if(p[i]!=0){
            printf(" %d %.1f",i,p[i]);
        }     
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值