hdu 2602-Bone Collector

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602

 

题目描述:

 

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

 

 

 

题目大意:

输入T组测试数据,然后输入N(N个骨头)和V(背包的容量),接下来的两行,第一行输入每个骨头的价值,第二行输入每个骨头的容量,叫你求出背包能装下的最大价值。

 

题目分析:

这题是个简单的01背包问题,注意的一点就是不要把价值跟容量弄反了,状态转移方程:dp[j]=max(dp[j],dp[j-w[i]]+c[i]);

 

AC代码:

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;

int dp[1005],c[1005],w[1005];
int N,V,T;

int main()
{
    cin>>T;//T组测试数据
    while(T--)
    {
        cin>>N>>V;//输入骨头的数目和背包的容量
        for(int i=1;i<=N;i++)
            cin>>c[i];//每个骨头的价值
        for(int i=1;i<=N;i++)
            cin>>w[i];//每个骨头所占的空间
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++)
        {
            for(int j=V;j>=w[i];j--)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+c[i]);//状态转移方程
            }
        }
        cout<<dp[V]<<endl;
    }
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值