hdu 1010 Tempter of the Bone

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

 

题目描述:

 

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 

 

Sample Input

 

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

 

 

Sample Output

 

NO YES

 

 

 

 

题目分析:

dfs+剪枝,要注意的地方详见注释

 

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define LIM (nx>=1&&nx<=n&&ny>=1&&ny<=m&&!v[nx][ny])
const int maxn=8;
int v[maxn][maxn],much[maxn][maxn];
char s[maxn][maxn];
int n,m,t,sign;
int detx,dety;
int stax,stay;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
void dfs(int x,int y,int step)
{
    if(x==detx&&y==dety)
    {
        if(step==t)
            sign=1;//找到符合条件
        return;
    }
    if(step>=t)
        return;
    for(int i=0;i<4;i++)
    {
        int nx=x+dx[i],ny=y+dy[i];
        if(LIM)
        {
            v[nx][ny]=1;
            dfs(nx,ny,step+1);
            v[nx][ny]=0;
            if(sign)//只要找到一个满足条件的,以后的就不用再看了
                return;
        }
    }
}
int main()
{
    while(1)
    {
        scanf("%d%d%d",&n,&m,&t);
        if(!(m||n||t))
            break;
        sign=0;
        memset(v,0,sizeof(v));
        for(int i=1;i<=n;i++)
        {
                scanf("%s",&s[i][1]);
                for(int j=1;j<=m;j++)
                {
                    if(s[i][j]=='X')
                        v[i][j]=1;
                    else if(s[i][j]=='S')
                        {
                            stax=i;
                            stay=j;
                            v[i][j]=1;
                        }
                    else if(s[i][j]=='D')
                    {
                        detx=i;
                        dety=j;
                    }
                }
        }
        if((abs(detx-stax)+abs(dety-stay)>t)||((detx+dety+stax+stay+t)%2==1))//这一步剪枝特别重要,可以减少700~800ms,(detx+dety+stax+stay+t)%2==1这一步看不懂的小伙伴可以去aoj667 看看,会找到灵感
        {
            printf("NO\n");
            continue;
        }
        dfs(stax,stay,0);
        if(sign)
            printf("YES\n");
        else
            printf("NO\n");
    }
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值