对于大数__int128的使用

对于大数__int128的使用

__int64是可以直接使用的,相当于 long long int。但是呢这个不是最大的。最大的可以调用__int128。
唯独区别的就是赋值和输出需要用函数来实现。
首先看看怎么用。

例如:
计算 a+b的值

int main() {
__int128 a = read();
__int128 b = read();
write(a + b);
return 0;
}

OK咱们现在实现read()和write()

read()

inline __int128 read() {
	__int128 x=0,f=1;
	char ch=getchar();
	while(ch<'0'||ch>'9') {
		if(ch=='-')f=-1;
		ch=getchar();
	}
	while(ch>='0'&&ch<='9') {
		x=x*10+ch-'0';
		ch=getchar();
	}
	return x*f;
}

write()

inline void write(__int128 x) {
	if(x<0) {
		putchar('-');
		x=-x;
	}
	if(x>9)write(x/10);
	putchar(x%10+'0');
}

举个栗子
a+b+c+d=?
问题描述

This is a very simple problem! Your only job is to calculate a + b + c + d

输入

There are several cases.In the first line, there is a single integer T.(T <= 200)In the next T lines, each line contains four integers a, b, c and d。(-2^63 <= a,b,c,d <=2^63)

Sample Input

1
1 2 3 4

Sample Output

10

很明显数据太大
4倍根本写不过来,所以用__int128是是个好想法

代码如下

#include <bits/stdc++.h>
using namespace std;
inline __int128 read() {
	__int128 x=0,f=1;
	char ch=getchar();
	while(ch<'0'||ch>'9') {
		if(ch=='-')f=-1;
		ch=getchar();
	}
	while(ch>='0'&&ch<='9') {
		x=x*10+ch-'0';
		ch=getchar();
	}
	return x*f;
}
inline void write(__int128 x) {
	if(x<0) {
		putchar('-');
		x=-x;
	}
	if(x>9)write(x/10);
	putchar(x%10+'0');
}
int main() {
	int n;
	cin>>n;
	while(n--) {
		__int128 a=read();
		__int128 b=read();
		__int128 c=read();
		__int128 d=read();
		write(a+b+c+d);
		putchar('\n');
	}
	return 0;
}

by-轮月

  • 2
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Round moon

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值