hdu 5480 Conturbatio

A - Conturbatio
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place. 

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook? 

Input

The first line of the input is a integer  , meaning that there are   test cases. 

Every test cases begin with four integers 
 is the number of Rook,   is the number of queries. 

Then   lines follow, each contain two integers   describing the coordinate of Rook. 

Then   lines follow, each contain four integers   describing the left-down and right-up coordinates of query. 






Output

For every query output "Yes" or "No" as mentioned above.

Sample Input

2
2 2 1 2
1 1
1 1 1 2
2 1 2 2
2 2 2 1
1 1
1 2
2 1 2 2

Sample Output

Yes
No
Yes

问题描述
在一个n \times mn×m的国际象棋棋盘上有很多车(Rook),其中车可以攻击他所属的一行或一列,包括它自己所在的位置。
现在还有很多询问,每次询问给定一个棋盘内部的矩形,问矩形内部的所有格子是否都被车攻击到?
输入描述
输入文件包含多组数据,第一行为数据组数TT。
每组数据有4个正整数n , m , K , Qn,m,K,Q。
KK为车的数量,QQ为询问的个数。
接下来有KK行,每行两个整数x , yx,y , 表示车所在的坐标。
再接下来有QQ行,每行4个整数x1 , y1 , x2 , y2x1,y1,x2,y2,表示询问的矩形的左下角与右上角的坐标。

1\leq n , m , K , Q \leq 100,0001≤n,m,K,Q≤100,000.
1\leq x \leq n , 1 \leq y \leq m1≤x≤n,1≤y≤m.
1\leq x1 \leq x2 \leq n , 1 \leq y1 \leq y2 \leq m1≤x1≤x2≤n,1≤y1≤y2≤m.
输出描述
对于每组询问,输出Yes或No。
输入样例
2
2 2 1 2
1 1
1 1 1 2
2 1 2 2
2 2 2 1
1 1
1 2
2 1 2 2
输出样例
Yes
No
Yes
Hint
输入数据过大,建议使用scanf

前缀和.:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int T,n,m,Q,R,a,b,sx,sy,ex,ey;
int x[maxn],y[maxn];
int xx[maxn],yy[maxn];

int main(){
	scanf("%d",&T);
	while(T--){
		memset(xx,0,sizeof(xx));	memset(yy,0,sizeof(yy));
		scanf("%d%d%d%d",&n,&m,&R,&Q);
		for(int i=0; i<R; ++i){
			scanf("%d%d",&a,&b);
			xx[a] = 1;	yy[b] = 1;
		}
		
		for(int i = 2; i <= n; ++ i)
        	xx[i] += xx[i-1];
   		for(int j = 2; j<= m; ++ j)
        	yy[j] += yy[j-1];
		
		
		for(int t=0; t<Q; ++t){
			scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
			if(xx[ex]-xx[sx-1] == ex - sx + 1 || yy[ey]-yy[sy-1] == ey - sy + 1)
				printf("Yes\n");
			else
				printf("No\n");
		}	
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值