hdu5480Conturbatio(好题)

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 156    Accepted Submission(s): 79



Problem Description
There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?
 

Input
The first line of the input is a integer T , meaning that there are T test cases.

Every test cases begin with four integers n,m,K,Q .
K is the number of Rook, Q is the number of queries.

Then K lines follow, each contain two integers x,y describing the coordinate of Rook.

Then Q lines follow, each contain four integers x1,y1,x2,y2 describing the left-down and right-up coordinates of query.

1n,m,K,Q100,000 .

1xn,1ym .

1x1x2n,1y1y2m .
 

Output
For every query output "Yes" or "No" as mentioned above.
 

Sample Input
  
  
2 2 2 1 2 1 1 1 1 1 2 2 1 2 2 2 2 2 1 1 1 1 2 2 1 2 2
 

Sample Output
  
  
Yes No Yes
Hint
Huge input, scanf recommended.
 

Source
BestCoder Round #57 (div.2)


/*
可以发现如果一个矩阵被全部攻击到,
很显然要么是因为它的每一行都有车,
或者每一列都有车。
所以只需要记录一下哪些行和哪些列有车,
对于每个询问只需要做一个前缀和就可以知道答案了。
*/
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
int x[101000],y[100010];

int main(){
    int t;
    scanf("%d",&t);
    int n,m,K,Q;
    int x1,x2,y1,y2;
    while(t--){
        scanf("%d%d%d%d",&n,&m,&K,&Q);
        mem0(x);
        mem0(y);
        while(K--){
            scanf("%d%d",&x1,&y1);
            x[x1]=1;
            y[y1]=1;
        }
        for(int i=1;i<=n;i++)
            x[i]+=x[i-1];
        for(int j=1;j<=m;j++)
            y[j]+=y[j-1];
        while(Q--){
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            if(x[x2]-x[x1-1]==x2-x1+1||y[y2]-y[y1-1]==y2-y1+1)
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值