[PYTHON](PAT)1061 DATING(20 分)

43 篇文章 0 订阅
通过分析字符串中的共享字符,解码出代表星期、小时和分钟的编码,帮助Sherlock Holmes解读神秘约会时间。
摘要由CSDN通过智能技术生成

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

题目大意

给定四个字符串,从前两个字符串中找到两个重合的字符,第一个要求在A-G内,代表的是星期。第二个要求在0-9或A-N内,代表的是小时。

从后两个字符串中找到一个重合的字符,要求是字符。出现的所在位置代表了分钟。

最后格式化输出即可

Python实现

if __name__ == "__main__":
    get = []
    day = ['MON', 'TUE', 'WED', 'THU', 'FRI', 'SAT', 'SUN']
    result = ''
    for x in range(4):
        get.append(input())
    hasday = False
    for x in range(min([len(get[0]), len(get[1])])):
        if get[0][x] == get[1][x] :
            if not hasday:
                if 'A' <= get[0][x] <= 'G':
                    result =result + day[ ord(get[0][x]) - 65]+' '
                    hasday = True
            else:
                if 'A' <= get[0][x] <= 'N' :
                    result =result+ str(ord(get[0][x]) - 55)+':'
                    break
                elif '0'<=get[0][x]<'9':
                    result = result+'0' + get[0][x]+':'
                    break
    for x in range(min([len(get[2]), len(get[3])])):
        if get[2][x] == get[3][x] :
            if 'a'<= get[2][x] <='z' or 'A' <= get[2][x] <= 'Z':
                if x < 10:
                    result = result + '0' + str(x)
                    break
                else:
                    result = result + str(x)
                    break
    print(result)

Python写PAT甲级,答案都在这了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值