[Python](PAT)1045 Favorite Color Stripe (30 分)

43 篇文章 0 订阅

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

题目大意

给定喜欢的序列和待挑选的序列,在待挑选的序列中去掉不喜欢的颜色,然后找到符合喜欢的序列的顺序的最长子列,不一定要包含喜欢的序列中的所有元素。

分析

使用dic保存喜欢的序列中各个元素出现的顺序,然后将给定的序列去除掉不喜欢的颜色后,转换成该元素对应在喜欢的序列中出现的位置,使用chain数组保存。

遍历chain中的每一个元素,判断它前面的序列中是否有比它小的元素,即在喜欢的序列中出现在它前面的元素。如果没有,则说明该元素只能作为一个子列的起始,在num字典中,以该元素为键值存储,值为1.如果存在出现在它之前的元素,则取出在num字典中的最大值a,更新该元素在num字典中的值为a+1,并判断是否大于result,如果大于则更新result。

最后输出result即可。

python实现

def main():
    n = int(input())
    line = input().split(" ")
    like = [int(x) for x in line[1:]]
    dic = {like[x]:x for x in range(len(like))}
    line = input().split(" ")
    chain = [dic[int(x)] for x in line[1:] if int(x) in like]
    num = {x:0  for x in range(n)}
    result = 1
    for x in range(len(chain)):
        now = chain[x]
        temp = sorted([ [i, num[i]] for i in num if i <= now], key = lambda j : -j[1])
        if len(temp) == 0:
            num[now] = 1
        else:
            num[now] = temp[0][1] + 1
            if num[now] > result:
                result = num[now]
    print(result)

if __name__ == "__main__":
    main()

python写PAT,答案都在这了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值