[C++] PAT 1045 Favorite Color Stripe (30分)

在这里插入图片描述

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

题解:

该题运用动态规划,使用最长增长子序列(LIS)思想,在更新dp数组时需要判断当前颜色 i 和 i之前的颜色j,满足c_order[i] >= c_order[j]以及dp[j]+1 > dp[i],再更新dp[i]

#include <iostream>

using namespace std;

int n,m,l;
int c_order[210];
int	cl[10010];
int dp[10010];



int main(){
	fill(c_order,c_order+210,-1);
	
	cin >> n >> m;

	int temp;
	for(int i=0;i<m;i++){
		cin >> temp;
		c_order[temp] = i;
	}
	
	cin >> l;
	int index = 0;
	for(int i=0;i<l;i++){
		cin >> temp;
		if(c_order[temp] != -1){
			cl[index] = temp;
			index++;
		}
	}

	int ans = 0;
	for(int i=0;i<index;i++){
		dp[i] = 1;
		for(int j = 0;j<i;j++){
			if(c_order[cl[i]] >= c_order[cl[j]] && dp[j]+1 > dp[i]){
				dp[i] = dp[j] + 1;
			}
		}
		ans = max(ans,dp[i]);
	}

	cout << ans;

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值